celenron mendocino

Sprzęt troll 01-01-1970 5781 34
17-08-2012 20:22
mam komputer z celeronem mendocino 433 mhz i 32 mb ramu + płyta główna i 6gb hdd.
problem polega na tym że jest czarny obraz mimo poprawnie zbudowany. pod grafiką isa pluje że bios wyczyszczony pod agb nie widzi mi obrazu mimo prób nvidia gforce mx200 32 mb, rivatnt 32mb, ati rage pro 4mb agp nic czysty obraz czarny. co robić?
17-08-2012 21:51
Dostałeś ten komputer jako niesprawny?
Ja znam te objawy. To bardzo często jest błąd w sztuce flashowania BIOSu. Albo atak wirusa czarnobylskiego.
Problem jest następujący: Z jakichś przyczyn BIOS jest do niczego. BIOS jako program, nie jako ustawienia. Dlatego komputer uruchamia minimalny sterownik zwany Bootblock, który potrafi:
a. Obsłużyć kartę grafiki TYLKO na szynie ISA.
b. Obsłużyć stację dyskietek 3.5" i uruchomić się z niej w stopniu znacznie ograniczonym.
c. Nieliczne potrafią obsłużyć jeszcze w wąskim stopniu klawiaturę.

Musisz mieć:
1. Dyskietkę bootowalną DOSa i plik himem.sys z tego DOSa
2. Plik z BIOSem do tego modelu płyty
3. Program do flashowania BIOSu (jak to Award to awdflash)

Nagraj 3 pliki: Himem.sys, BIOS i program do flashowania na dyskietkę, i wprowadź na nią kolejne dwa pliki:

config.sys o treści:
device=himem.sys
autoexec.bat o treści:
Awdflash bios.bin /Py /Sn
gdzie bios.bin to nazwa pliku z BIOSem.

Wkładasz kartę na ISA, wkładasz dyskietkę do stacji, power on i zobaczymy. To jest pod BIOSa Awarda, jak masz AMI nie używasz AWDFlash, i inne parametry z tego, co pamiętam są.

Do znalezienia BIOSu przydałby się dokładny model płyty głównej, rewizja płyty (jak na płycie jest napis np. rev. 1.0 to to jest to), jak i napisy na kości BIOSu (Award, Phoenix, czy może AMI i charakterystyczne logo z trójkątami?).
18-08-2012 16:51
bios award na płytce z biosem następujące napisy: SyncMOS 9944 f29c51002t-po lub c gdyż jest zasłonięte naklejką o oznaczeniu award 1998 pci/pnp 686 a pod spodem  224132059 nazwa płyty -?- bo nie pisze :( gniazdko pga370 ta pierwsza wersja)
18-08-2012 19:57
Dobra, BIOS będzie Awarda, czyli trzeba będzie użyć awdflash. Poszukaj tej nazwy, powinna gdzieś być. Między slotami, czy na brzegach, powinno być coś napisane. Rzadko się zdarza, by producent pisał w całości, często pisze tylko oznaczenie typu np. "SL45U2".
18-08-2012 21:08
nie ma nazwy nigdzie wrzuciłem filmik z tel komórkowego w formacie 3gp
  http://w402.wrzuta.pl/film/2oVz7W2vv1u/v18-08-12_20.51 - pod spodem przy isie jest napis niewidoczny dla kamery vga o oznaczenie 35-c931-00-20.
19-08-2012 00:52
Dziękuję. Wszystko wiem. To PC Partner. Nudzi mi się i pomimo zarwania poprzedniej nocy nie mogę zasnąć, to wszystko Ci przygotuję :)

EDIT
Dobra. To masz wszystko w dołączonym pliku, nie musisz pisać skryptów z mojego poprzedniego postu :). Potrzebujesz tylko pustej dyskietki i komputera ze stacją dyskietek i Windowsem. Musisz zrobić dyskietkę do ratowania płyty na jakimś sprawnym komputerze z Windowsem i stacją dyskietek (może być stacja na USB).
Rozpakuj plik. Wejdź w folder BIOS potem AUTOFLASH, uruchom RawWriteWin.exe.
Kliknij zakładkę Write.
Floppy drive - wybrać stację dyskietek (z reguły jest jedna już wybrana).
Image file (kliknąć w  "...") - wybrać plik autoflash.img
Włożyć pustą dyskietkę do stacji.
Kliknąć WRITE. Nagra się dyskietka. Teraz z tej dyskietki trzeba uruchomić uszkodzony komputer (z włożoną kartą grafiki ISA i podłączoną klawiaturą) i zobaczyć co się stanie.
Jeżeli nie powiedzie się, zobaczymy co się stało. Może to być jakaś eksportowa wersja płyty i wtedy kicha, bo producent udostępniał tylko taki BIOS.

Jeżeli komputer uruchomi się z dyskietki, wyświetli ramki i bloczki zaczną się zmieniać, to tak ma być. Jak nie, podaj co dzieje się na ekranie. Nie wolno wyłączać zasilania komputerowi jak pracuje bloczkami :). Dopiero gdy skończy i pokaże to na monitorze, to można komputer wyłączyć, wyjąć dyskietkę, a potem włączyć i zobaczyć jaki efekt.

Generalnie płyta jest aktualnie zarżnięta BIOSem i ciężko zarżnąć ją w gorszym stopniu.

P.S.
Jeszcze drobna uwaga. Ta dyskietka ma teraz to do siebie, że każdemu komputerowi, który się z niej uruchomi wepcha do pamięci BIOSa płyty PC Partner bez ostrzeżenia. Innym płytom takie coś nie wychodzi na zdrowie, więc radzę, gdy dyskietka nie będzie już potrzebna, sformatować ją.
19-08-2012 12:00
z tego co zauważyłem troll jest userem m.in. linuxa. obraz może wrzucić na flopa komendą: dd if=/home/user/autoflash.img of=/dev/fd0 o ile obraz dyskietki znajduje się w /home/user. Dobrze było by gdyby dyskietka była nowa, a podczas flaszowania komp był podpięty do sieci przez ups. utrata zasilania może uszkodzić bootloader biosu, wtedy zostają dwie opcje: programator, albo hotswap i programowanie flashki na innej płycie ( moja ulubiona metoda :D )
19-08-2012 13:46
Obraz w RAWie to jest format uniwersalny, więc o ile Linuksowi zachce się wykryć /dev/fd0, będzie można bez problemu to wgrać. Co do nowej dyskietki, dobrym obyczajem RaWrite (szczerze mówiąc poleciałem tu trochę i przyjąłem, że RawWriteWin też) jest sprawdzanie po sobie. Generalnie dyskietka musi być czytelna.

Ja całkowicie zepsute BIOSem płyty ożywiałem programatorem (dopóki starczał Willem 3), chociaż hotswap raz robiłem. W jednej płycie działającej u mnie do dziś jako sprzęt do testowania (choć płyta nie jest szczególnie stara - działa w niej Celeron 1.7) znajduje się wielki EPROM 27C040, wmontowany niezbyt poprawnie (wlutowany był w SMD prosty Flash).
Płytę tą dostałem z serwisu jako z "nienaprawialnym uszkodzeniem BIOSu"... No i wyszło "ja nie naprawię?" :)
Aktualnie wygląda to tak, że z  gały termogluta na płycie zwisa gąszcz izolowanych kabelków, na nich wisi kawałek płytki uniwersalnej z podstawką EPROMa, podklejony styropianem dla uniknięcia zwarć, plus walają się jakieś diody (coś chyba musiałem ORować). Płyta działa od 4 lat.
Dla próbujących tak jechać po bandzie - nie wszystkie EPROMy zawsze działają.
19-08-2012 16:32
mam podobne cudo i tak samo odziedziczone po serwisie:
abit bx133-raid a na nim eprom 27C512 (kasowanie uv) zawierający bios. na epromie dolutowana podstawka precyzyjna (eprom i podstawka mają odgięte nóżki CE które są podłączone do zwykłego przełącznika dwupozycyjnego < podstawka >>. płyta ta służy mi wyłącznie do wgrywania biosów na kości
19-08-2012 17:48
dobra jest problem uruchomienie jest tylko przy starcie później po testowaniu przy uruchomieniu nic nie chce się pojawić i zwis na całej linii dopiero po wyłączeniu zasilacza pstryknięciem z tyłu i ponownym uruchomieniem się pojawia napis. udało mi się zapisać nazwę płyty głównej jest to 01/11/2000/440BX/ITE671-2A69KV3IC-00 po sprawdzeniu
i wykryciu dysków twardych i napędów jest zwis i czarny ekran oraz kreseczka migająca jak w dosie u góry czyli -
19-08-2012 19:25
Teraz to nie zrozumiałem.
Kiedy nagle wskoczył pełny BIOS?
BIOS generalnie ma pewien zestaw komunikatów, które tłumaczone na język polski są dość mylące i utrudniają ustalenie źródła problemu.
19-08-2012 20:10
i to jest najdziwniejsze :) najpierw pluł że bios jest wyczyszczony i zwis a teraz bios chodzi normalnie (da się na niego wejść i zobaczyć menu ) później zwis to znaczy po uruchomienu i wykryciu napędów ale tylko na karcie graficznej pod szyną isa na agp już nie wchodzi i czarny ekran co może być nie tak? zworki źle ustawione? nawet nie chce bootować z fdd ani z hdd nic nawet nie chce włączyć ostatniej ramki po włączeniu jest tylko czarny ekran i - migające.
19-08-2012 20:22
komp zawisa ci przed komunikatem POST (taka ramka z podsumowaniem). czy podczas flashowania biosu nie było tak ze pasek postepu po 3/4 operacji tyklo migną i nagle 100% ok? jeśli tak to zostały w kości jakieś stare śmieci.
awdflash ma przełącznik wymuszający nadpisanie zapisanych w kości ustawień.

możliwym też jest uszkodzenie jednej z kości pamięci, jednak na początek polecał bym wyjąć baterie CMOS na jakieś 10 minut minimum, a po włożeniu wgrać bios normalnie z czyszczeniem cmos
awdflash /P /CC plik_biosu.bin


tu sznurek : ftp://207.215.188.219/POS85M/Driver/Flash/

edit:

aj nie zobaczyłem ze nawet flop ci nie śmiga :/

w takim razie odepnij od płyty wszystko co zbędne, zostaw tylko grafe na isa i flopa i zobacz czy startuje jak należy. jeżeli masz kilka pamięci ram zostaw tylko jedną, jak nie zatrybi, zmien pamięć lub slot w który jest włożona
20-08-2012 00:19
No to jedziemy po hardwarze.
1. Jak ustawione są JP8 i JP23 (jeżeli wlutowane)? Tymi okazami można załatwić płytę tak, że będzie widziała połowę kości.
2. Wejść do Setupu i załadować BIOS defaults. Zapisać, wyjść.
2. Spróbować zresetować ustawienia CMOS zworką JP4 (pozycja 2-3).
20-08-2012 14:45
jp8 jest na u góry od spodu gniazdek odpowiednio na 1-2 jp23 zaś 2-3
21-08-2012 01:43
Spróbuj załadować Setup Defaults, a jak nie pomoże, to JP4 na 2-3, potem przywrócić na 1-2.
Co do JP8 i JP23, to czy są jakieś ślady, że te zworki były grzebane? Bo to jest dziwne, kość SyncMOS ma pojemność 2MBit (256KB, mniej wiecej tyle, co wsad BIOSu), a zworki są ustawione na kość jedno megabitową. Możliwe, że zostało zmienione, po czym BIOS stał się nieczytelny a możliwe, że tylko pół kości jest wykorzystywane (jedna linia adresowa jest trzymana "na twardo").

Dhg, nie wiesz może, czy BIOS może zastartować jak jest w połowie? Jeżeli obcięło np. moduły kontrolerów dyskowych.
21-08-2012 10:59
MCbx: 100% pewności nie mam ale jest to możliwe. Z tego co się orientuje poszczególne moduły biosu są ułożone tak aby były wybierane przez osobne linie adresowe. Pod pierwszym adresem A0 zawsze jest bootblock inicjujący bios. Oczywiście to teoria wynikająca z obserwacji zachowania sprzętu, komputer nawet ze złym flashem można uruchomić, o ile bootblock ma procedure testująco-naprawczą, czyli słynny autoflash.

Zastanawia mnie jeszcze jedna sprawa:
troll czy podstawka biosu przypadkiem nie ma czarnego nalotu na stykach? Na wszelki wypadek kilka razy wyjmij i włóż kośc biosu. wszystkie problemy mogą wynikać z braku styku między kością a płytą.
21-08-2012 15:17
problem polega na tym że pisze cmos crc fail press disk in a: lub po się uruchamia bios i po uruchomieniu ostatniej informacji gdy nadejdzie uruchomienie os zwis klawiatury i kicha nie chce nawet mi wejść do biosu bo jest zwis już podczas wejścia i nawet nie mogę nic zrobić z biosem albo pokazuje się ten napis co jest grane?
21-08-2012 15:41
@troll, a nie łatwiej byłoby pójść po bandzie i poszukać nowej płyty? Z tego co wiem Mendocino był przystosowany do S370, a jeszcze nie jest największym problemem znaleźć kompatybilny mainboard. Np. dzisiaj w moim byłym gimnazjum była inwentaryzacja, "wyrwałem" 3 komputery z PIII Coppermine 600MHz, w tym jeden "serwer" oparty na SBS 4.5. Wszystko za darmochę. :D
21-08-2012 16:57
chyba też dam se z tą płytą spokój bo się poddałem . kupię za grosze amd athlona xp + płyta główna w miejsce tego mendocino. za ok 100 zł komp jak się marzy do zadań z ze starymi grami i dosboxem :) + c64 + pegasus i amiga.

Aby móc odpowiedzieć w tym wątku, zaloguj się.